Frequently Asked Questions

Below you’ll find answers to most of the questions that users have regarding the purchase, download, installation, and use of our products. They also include some troubleshooting tips in case you’re encountering errors during any step and need help resolving it.


I have Adobe Photoshop Elements. Can I use any of these products?

Unfortunately, you will need a full version of the Photoshop program — Elements won’t suffice for using these products.

One possible exception is moirai Surface which is primarily a collection of texture images. Those images can be opened and used in Elements. However, the techniques shown in the included video for actually applying the textures to your photographs require Photoshop.

What version of Photoshop do I need to use these products?

Each product page indicates the minimum required version. Currently, all of the script products require Photoshop CS4 or higher. The action set (moirai Achieve) only requires Photoshop 7.0 or higher.

What is your policy on product updates and supporting older and new versions of Photoshop?

Only our script products require updates for compatibility and bug fixes. Other products (like moirai Achieve and moirai Surface) are not expected to need any updates.

Updates for compatibility and bug fixes are called patches. Patches are provided free of charge. When a new patch is available, we will post a news item on this site. You can then login to the downloads area (using the link sent to you when you purchased your product) and download the latest revision, which will include the patch. For major patches — like for compatibility with a new release of Adobe Photoshop — we will send an announcement via email to all of our customers (using the email address we have on file, which is the one associated with the PayPal account you used to purchase a product).

New versions of our products will generally include new enhancements and features and will not be free. But they will be made available to existing customers at a discounted upgrade rate. Once we have released a new version of a product, we will continue to support older ones for at least 12 months and continue to release patches for older ones, if necessary, during this time. After that 12 month period ends, customers are urged to upgrade in order to continue getting patches and support.


How long will it take for my payment to be confirmed?

Payments are generally confirmed by PayPal within 5 minutes. However, paying by eCheck can require much more time as the check must clear before the payment is confirmed. It can take several business days for a check to clear.

Once we receive payment confirmation, an automated email will be sent to you with the details on how to download your product. Keep in mind that your email program might mistakenly classify our message as spam, so be sure to look in your junk mail folders before inquiring with us.

What is your refund policy?

If you have not downloaded the product, we can issue you a full refund. However, once you download the product, refunds can only be given for exceptional circumstances since we have no way to prevent you from continuing to use the product.

Exceptional circumstances include if you accidentally pay for an item twice or if a charge is made fraudulently. Other circumstances will be considered. So if you think you deserve a refund, please contact support.

Partial refunds can be given in other situations. For example, if you purchase a product and then immediately purchase others that are included in our suite. In this case, we can provide a partial refund for the difference between the total you paid and the price of the suite.

Purchases and Downloads

I keep getting Unauthorized errors when I try to login and download my purchase. How can I download it?

You will need to doublecheck that you are using the correct username and password, without any typos. Keep in mind that both usernames and passwords are case-sensitive, so make sure the Caps Lock is off. The best bet is to simply use copy+paste to copy the username and password out of the email you received and paste them into the browser.

If you’ve tried the above suggestions and still can’t get in, contact support to get more information on what you might be doing wrong or to get problems corrected in case there is a system issue preventing your access.

My account has been disabled, and I can't login. How can I download my purchase?

This happens when you try to make too many download requests. This could happen if other people were using your credentials to download the product without purchasing it, which is why an account gets disabled when this is detected.

It could be caused by repeated attempts to download — like if you have a bad internet connection and have to try several times before the entire product is successfully downloaded. It can also happen if you use a download manager. So please disable any download manager software or configure it to only use a single connection at a time when downloading from our servers.

Once your account has been disabled, you will need to contact support to get it re-enabled and to have the download history cleared so you once again get access and download your files.

I forgot my password. How can I login and download an update?

Passwords are long and randomly generated by the system for maximum security, so it is not expected that you remember them. You should instead keep the email you received that included the username and password. You can then copy the password from the email and paste into the browser when logging in.

If you have lost the original notification email, you can simply request a new password. A new password will be generated and a new notification email will be sent. You can then copy and paste that new password to login to the downloads area of the site.

I forgot my user ID. How can I login and download an update?

Your user ID will be the email address associated with the PayPal account you used to purchase the product. Please take a look at your PayPal notification email or login to the PayPal site to find this information.

If you are uncertain, you can contact support and receive assistance in tracking down this user ID. Support will likely need some additional information, like your name, the date on which you made the purchase, and/or the PayPal transaction ID.

When I purchased the product, I received via an email attachment. How do I get an update?

Currently, when you purchase products, you get an email notice with information about how to login and download your purchase. If you purchased the product back when we instead sent products out via email attachment, you will need to get the download instructions.

You should have received an email from us with your initial login credentials and a link to the downloads area of our site (this was sent in June, 2012, along with notification of updates for Photoshop CS6). If you cannot find this notification (don’t forget to check your junk mail folders), you have a couple of options:

  • You can request a new password. Use the email address you used to purchase the product as your login ID.
  • You can contact support and get assistance, including re-sending of the original notification email.

I lost the email that was sent after I purchased the product and I got a new computer. How can I get the product to install on my new computer?

As long as you still have the email address used to purchase the product, you are in good shape and have a couple of options:

  • You can request a new password. Use the email address you used to purchase the product as your login ID.
  • You can contact support and get assistance, including re-sending of the original notification email.

Once you have usable login information, you can simply login, re-download the product, and install it on your new computer.

I lost the product archive that I received/downloaded. Where can I find the user guide that was included with it?

You can download the archive again and find the user guide included in that download.


When I try to install using the Adobe Extension Manager on MacOS, I get an error: The extension cannot be installed. It requires Photoshop version 10|11 or higher. How do I install the software?

As of Photoshop CC 2015, Adobe no longer supports Extension Manager or extensions. Instead, they only support installation of extensions purchased through the Adobe Add-On Store. To install our software on these newer versions, you will need follow the instructions in the section of the user guide titled Manual Installation.

If you are on an older version of Photoshop but are using an earlier version of moirai Compositor or moirai Sequence, you are likely experiencing a different issue. Older versions of these products included packages (MXP files) that were not properly compatible with Mac OS X versions of Adobe Extension Manager. For those versions, you will need to follow the instructions in the section of the user guide titled Manual Installation.

Current versions do not have this problem anymore.

After installing manually, I do not see an option for running the script in the Photoshop menu. How can I get it to show up in the menu?

This usually happens when you have more than one version of Photoshop installed. On 64-bit Windows, even a single version of Photoshop (CS6 for example) includes two programs you can run: a 32-bit version and a 64-bit version.

If the scripts get installed for one version but you are actually running a different one, they will not show up in the menu. Make sure you’ve installed the scripts into the correct version of Photoshop. If the Adobe Extension Manager isn’t working, try following the instructions in the section of the user guide titled Manual Installation and pay particular attention to the path into which you are copying files.

Is there a way to run the product without installing it?

You don’t actually need to install the scripts to run them. You can just unzip the downloaded archives on to your hard drive and then choose File > Scripts > Browse… and then locate the JSX files where you unzipped them. This is much less convenient, so we strongly recommend installing the scripts instead.

Product Problems and Errors

The full previews in moirai Compositor v3 are blank or only show a single image and the rest is blank.

With Photoshop CC 2015, Adobe has unfortunately introduced a bug in Photoshop that prevents proper execution of moirai Compositor v3. The product usually performs fine on Mac OS X. However a few users have encountered issues where the preview window is completely blank. The problem is much worse on Windows, where most users have encountered an issue where only a single image is shown in the preview and the rest of the preview is blank.

We have filed a bug with Adobe and are hoping it gets fixed in the next Photoshop update. One thing that can be done if you experience this problem is to uncheck the Show full preview box, above the preview panel. This won’t render the images, unfortunately, but it least lets you see the relative size and location of elements in the layout.

To really work around this problem, you need to revert to a previous version of Photoshop. You can, for example, roll back to CC 2014, and everything should work correctly. If you no longer have the downloads for CC 2014, you can access them from this website:

After creating a composition, the final image doesn't look good. How can I make it look better?

The images created by moirai Compositor are normal Photoshop documents, so, depending on the artifacts in the image you’re not happy with, you may be able to do some adjustments to fix. If the images look pixelated then either your source images need to be higher resolution or larger OR your final composition should be smaller.

If you save images for the web (usually at a lower resolution and then sharpened), try doing that processing after you’ve created the composition. In other words, try using original/raw images as the sources for your composition and then running your web filters only on the final product. If you run web filters on each image first and then use those processed images in the composition, it may not look as good.

After installing manually, I get an error when I try to run the script: Error 48: File or folder does not exist. How do I use the program?

This generally means an incorrectly installed product. Under rare circumstances, this has been seen to happen on Windows when installing using the Adobe Extension Manager and working around this issue is done by following the directions in the user guide for the section titled Manual Installation.

If the product was manually installed, then it means that not all of the files were properly copied over into the Photoshop application folder. Specifically, the “resources” folder that is included with the script was not copied properly.

When I run the script, I get an error: Error 519: Server Interface Error. How do I use the program?

This error can be fixed by resetting your Photoshop preferences. See the user guide for instructions on how to reset preferences for your version of Photoshop.

When I run the Compositor, instead of seeing a preview of the layout, it just says null. How can I get the layout chooser to show me the layouts?

This occurs when an older version of moirai Compositor is run using Photoshop CS5 or newer. You will need to download and install a newer version of the script.

When I run the Compositor, the image list says [NaNxNaN] where it usually shows the image's size. If try to see a preview of the layout, it is blank. If I try to create a composition, it is also blank. How can I get the script to work?

Older versions would behave this way when your Units / Rulers preferences were set to use “percent” ( as opposed to inches, cm, pixels, etc.). This is fixed in recent versions so downloading and installing a newer version will fix this. Another work around is to change your preferences.

When I run the Compositor and click the Choose Layout button, it hangs and Photoshop is frozen. How can I create my composition?

In past versions of moirai Compositor, we imagined that 10 to 15 images was a lot. Users have since pushed the envelope with many more images. The easiest way to get past this is to upgrade to the latest version. It includes support for using hundreds of images in a single composition.

In prior versions, you can try creating multiple “tiles”, each one having just 10 to 15 images (some computers can handle as many as 20 in a single composition). Then you can assemble all of those compositions into one big one. Assembling the tiles can be done by moirai Compositor: just load the tiles as inputs to a new composition. In addition to letting you use lots of images this way, you can also get some very interesting layouts.

When I try to create the final composition in the Compositor, Photoshop crashes. How can I create my composition?

Adobe Photoshop CS4 had stability issues in the scripting runtime. It is not usually a problem, but on some computers it causes the entire application to crash when creating a composition. The user guide includes information on patches and how to search Adobe forums for tricks that may help. Upgrading to CS5 or higher generally resolves this issue.

When I choose layouts in the Compositor, the preview just shows a line. How can I create my composition?

Double-check the dimensions of your composition. If you have accidentally used a unit of inches when you meant to use pixels, you may end up with a composition that is really, really long in one direction and not the other. If the preview tries to show you a layout that is, for example, 1 x 1000, it will just look like a thin line. Try correcting the dimensions and try again.

When I try to create the final composition in the Compositor, nothing happens and no document is created. How can I create my composition?

This only happens under very rare circumstances. It usually indicates that Photoshop is unhappy with the composition and just aborts the process of creating it. The few times we’ve helped diagnose this problem, it was due to the final composition size being very, very large. Double-check that the resolution is reasonable and that the final size is reasonable and then try again.

Sending Information to Support

How do I figure out what version of the product that I am using?

In Photoshop, there is a menu option for finding the version of any extensions and plugins (on Windows this is at Help > About Plugin). If you locate the moirai product in this list, it will show you the current version. If the product was installed using the Adobe Extension Manager then you can open that and find the version of the product you have installed.

When contacting support, it is recommended that I include a log. How do I get a log?

Recent versions of all of our script products include a way to view log files. This option will be in the main menu: File > Scripts > moirai View Log Files. This will open a window from which you can select the pertinent product and then click a button to view the log. You can then just copy and paste the contents of the log file into an email.